Settlement Processing Delay

Incident Report for Wpay

Resolved

The issue resulting in a delay to settlements has been resolved. All settlements have been successfully processed.
Posted Aug 06, 2025 - 15:37 AEST

Investigating

We have identified an issue resulting in a delay to settlements.

Our support team is actively investigating the cause of the issue and working on a resolution.

We will post an update as soon as we have more information or when the issue is resolved.
Posted Aug 06, 2025 - 09:10 AEST
This incident affected: Payouts and Billing.